Welcome to the Siemens Asset Management Software Status Page — your go-to source for real-time updates on product and service health. Available 24/7/365, this page provides transparent, timely information about service availability, incidents, and resolutions. We're committed to keeping you informed with clear, reliable updates so you can stay confident in the services you rely on every day.
Get email notifications whenever Siemens Asset Management Software creates, updates or resolves an incident.
Get text message notifications whenever Siemens Asset Management Software creates or resolves an incident.
Get webhook notifications whenever Siemens Asset Management Software creates an incident, updates an incident, resolves an incident or changes a component status.
We have completed the scheduled maintenance. If you need assistance or more information, please contact Support at 1-877-655-3833 or ams-support.si@siemens.com.
Posted Jul 18, 2026 - 10:05 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 17, 2026 - 22:00 EDT
Scheduled
Siemens Asset Management Software will be performing scheduled maintenance on Friday, July 17th beginning at 10:00 PM ET to approximately 10:00 PM ET on Saturday, July 18th. Access to SchoolDude and Facility Dude products will be unavailable during this time. We apologize for any inconvenience this might cause. If you need assistance or more information, please contact Support at 1-877-655-3833 or ams-support.si@siemens.com.
Posted Jul 17, 2026 - 09:20 EDT
This scheduled maintenance affected: Work and Asset Management (MaintenanceDirect, PMDirect, Planned Maintenance, Work Order, CapitalForecastDirect, Critical Alarm Automation, SchoolDude WorkCenter, Capital Forecast, Critical Alarm, FacilityDude Work Center, InventoryDirect, Inventory), IT Asset Management (Incident), Event Management (Facility Schedule, FSDirect, FSAutomation, TripDirect), and Dude Intelligence, MySchoolBuilding, MyFacilityDude.